POJ 3050 Hopscotch

链接:http://poj.org/problem?id=3050

题目:

Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1869 Accepted: 1343

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

题意:有一个5*5的棋盘(当成是棋盘),每个格子上有一个数,从一个格子出发,走五步(每步只能到达相邻的格子),形成一个六位数(可以有前导0),问一共可以形成多少种不同的六位数。

解题思路:

搜索,DFS。以棋盘的每一个点为起点,进行DFS,将形成的所有六位数保存下来,再找出有多少个不同的六位数就可以了。


代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAXN = 100010;
int a[MAXN], map[6][6];
int d[4][2] = { {-1, 0}, {1, 0}, {0, -1}, {0, 1} };
int n;

void dfs(int ix, int iy, int cur, int v)
{
    if(6 == cur)
    {
        a[n++] = v;
        return ;
    }
    v = 10 * v + map[ix][iy];
    for(int i = 0; i < 4; i++)
    {
        int x = ix + d[i][0];
        int y = iy + d[i][1];
        if(x >= 0 && x < 5 && y >= 0 && y < 5)
        {
            dfs(x, y, cur + 1, v);
        }
    }
}

int main()
{
    n = 0;
    memset(a, 0, sizeof(a));
    for(int i = 0; i < 5; i++)
    {
        for(int j = 0; j < 5; j++)
        {
            scanf("%d", &map[i][j]);
        }
    }
    for(int i = 0; i < 5; i++)
    {
        for(int j = 0; j < 5; j++)
        {
            dfs(i, j, 0, 0);
        }
    }
    sort(a, a + n);
    int ans = 1;
    for(int i = 1; i < n; i++)
    {
        if(a[i] != a[i - 1])
        {
            ans++;
          //  printf("%d\n", a[i]);
        }

    }
    printf("%d\n", ans);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值