链接:http://acm.hdu.edu.cn/showproblem.php?pid=1253
题目:
胜利大逃亡
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24456 Accepted Submission(s): 9364
Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.
魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)
特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
Sample Input
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
Sample Output
11
bfs()裸题。ps:如果从起点到终点不可达,也要输出-1.
代码:
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
const int MAXN = 55;
int a, b, c, t, m, ans;
int map[MAXN][MAXN][MAXN];
bool vis[MAXN][MAXN][MAXN];
int dir[6][3] = {0, 0, 1, 0, 0, -1, 0, 1, 0, 0, -1, 0, 1, 0, 0, -1, 0, 0};
struct Point
{
int x, y, z, step;
};
queue<Point> q;
int bfs()
{
while(!q.empty())
{
q.pop();
}
memset(vis, false, sizeof(vis));
Point p;
p.x = p.y = p.z = p.step = 0;
q.push(p); vis[0][0][0] = true;
while(!q.empty())
{
Point src = q.front(); q.pop();
for(int i = 0; i < 6; i++)
{
Point tmp;
tmp.x = src.x + dir[i][0];
tmp.y = src.y + dir[i][1];
tmp.z = src.z + dir[i][2];
tmp.step = src.step + 1;
if(tmp.x < 0 || tmp.x >= a || tmp.y < 0 ||
tmp.y >= b || tmp.z < 0 || tmp.z >= c ||
1 == map[tmp.x][tmp.y][tmp.z] || vis[tmp.x][tmp.y][tmp.z])
{
continue;
}
if(tmp.x == a - 1 && tmp.y == b - 1 && tmp.z == c - 1)
{
return tmp.step;
}
q.push(tmp);
vis[tmp.x][tmp.y][tmp.z] = true;
}
}
return 0;
}
int main()
{
scanf("%d", &m);
while(m--)
{
scanf("%d%d%d%d", &a, &b, &c, &t);
for(int i = 0; i < a; i++)
{
for(int j = 0; j < b; j++)
{
for(int k = 0; k < c; k++)
{
scanf("%d", &map[i][j][k]);
}
}
}
ans = bfs();
if(0 == ans || ans > t)
{
printf("-1\n");
}
else
{
printf("%d\n", ans);
}
}
return 0;
}