hdu 4283 You Are the One

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4424    Accepted Submission(s): 2074


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 

Output
  For each test case, output the least summary of unhappiness .
 

Sample Input
  
  
2    5 1 2 3 4 5 5 5 4 3 2 2
 

Sample Output
  
  
Case #1: 20 Case #2: 24
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   4267  4268  4269  4270  4271 
 





给出一串数列,给这些数排顺序,代价是排在该数前面的数的数量乘上它本身的数字,求最终的代价和最小
这道题的状态转移方程是dp[i][j]=min(dp[i][j],a[i]*(k-1)+k*(ans[j]-ans[i+k-1])+dp[i+1][i+k-1]+dp[i+k][j]) 
可以从局部来看,将某一段区间单独来看,假设该段区间的a[i]是在该区间内的第k个,那么i后面的就可以拆成k*(ans[j]-ans[i+k-1])与以i+k到j为
区间的最优解的和。



#include<iostream>
#include<cstring>
using namespace std;
int main(){
    int a[111];
    int dp[111][111];
    int s[111];
    int t,cs=1;
    cin>>t;
    while(t--)
    {
        int num;
        int i,j,k;
        cin>>num;
        s[0]=0;
        for(i=1;i<=num;i++)
        {
        cin>>a[i];
        s[i]=s[i-1]+a[i];
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=num;i++)
        {
            for(j=i+1;j<=num;j++)
            dp[i][j]=99999999;
        }
        for(i=1;i<num;i++)
        {
            for(j=1;j<=num-i;j++)
            {
                int lm=j+i;
                for(k=1;k<=lm-j+1;k++)
                dp[j][lm]=min(dp[j][lm],dp[j+1][j+k-1]+dp[j+k][lm]+k*(s[lm]-s[j+k-1])+a[j]*(k-1));
            }
        }
        cout<<"Case #"<<cs++<<": ";
        cout<<dp[1][num]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值