There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.
Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).
It is guaranteed that the sum of all n does not exceed 5000.
We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.
Output
For each case, you should output one integer denoting the maximum comfort.
Sample Input
2 3 10 1 5 1 2 10 2 1 10 2 10
Sample Output
191 0
Hint
For the first case, Edward should select the first and second courses.
For the second case, Edward should select no courses.
没想到是一道01背包题,给定hi ci2串数字,拿出相同长度的2个子序列,带入给出的方程求最大。
根据公式可以得出,ci固定求hi最大即可,后面就是01背包的过程,ci作为背包容量,hi作为价值即可。
#include<map>
#include<set>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<iomanip>
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
int t;
cin>>t;
while(t--)
{
int num;
cin>>num;
long long int h[555];
long long int c[555];
int i,j;
for(i=1;i<=num;i++)
{
scanf("%d%d",&h[i],&c[i]);
}
long long int dp[55555];
memset(dp,0,sizeof(dp));
for(i=1;i<=num;i++)
{
for(j=50000;j>=c[i];j--)
{
dp[j]=max(dp[j],dp[j-c[i]]+h[i]);
}
}
long long int ans=0;
for(i=1;i<=50000;i++)
{
ans=max(ans,dp[i]*dp[i]-i*dp[i]-(long long int)i*i);
}
cout<<ans<<endl;
}
return 0;
}