1562: Fun House
Time Limit: 1 Sec Memory Limit: 128 Mb Submitted: 498 Solved: 176Description
American Carnival Makers Inc. (ACM) has a long history of designing rides and attractions. One of their more popular attractions is a fun house that includes a room of mirrors. Their trademark is to set up the room so that when looking forward from the entry door, the exit door appears to be directly ahead. However, the room has double-sided mirrors placed throughout at 45 degree angles. So, the exit door can be on any of the walls of the room. The set designer always places the entry and mirrors, but can never seem to be bothered to place the exit door. One of your jobs as part of the construction crew is to determine the placement of the exit door for the room given an original design.
The final diagram for a sample room is given below. The asterisk (*) marks the entry way, lower case x's mark the walls, the mirrors are given by the forward and backward slash characters (/ and \), open spaces with no visual obstructions are marked by periods (.), and the desired placement of the exit is marked with an ampersand (&). In the input diagram, there is an 'x' in place of the '&', since the exit has not yet been located. You need to alter the input diagram by replacing the proper 'x' with an '&' to identify the exit. Note that entrances and exits can appear on any of the walls (although never a corner), and that it is physically impossible for the exit to be the same as the entrance. (You don't need to understand why this is so, although it may be fun to think about.)
xxxxxxxxxxx
x../..\...x
x..../....x
*../......x
x.........x
xxxxxx&xxxx
Input
Each room will be preceded by two integers, W and L, where 5 ≤ W ≤ 20 is the width of the room including the border walls and 5 ≤ L ≤ 20 is the length of the room including the border walls. Following the specification of W and L are L additional lines containing the room diagram, with each line having W characters from the alphabet: { * , x , . , / , \ }. The perimeter will always be comprised of walls, except for one asterisk (*) which marks the entrance; the exit is not (yet) marked. A line with two zeros indicates the end of input data.
Output
For each test case, the first line will contain the word, HOUSE, followed by a space and then an integer that identifies the given fun house sequentially. Following that should be a room diagram which includes the proper placement of the exit door, as marked by an ampersand (&).
Sample Input
11 6 xxxxxxxxxxx x../..\...x x..../....x *../......x x.........x xxxxxxxxxxx 5 5 xxxxx *...x x...x x...x xxxxx 5 5 xxxxx x./\x *./.x x..\x xxxxx 6 6 xxx*xx x/...x x....x x/./.x x\./.x xxxxxx 10 10 xxxxxxxxxx x.../\...x x........x x........x x.../\..\x *...\/../x x........x x........x x...\/...x xxxxxxxxxx 0 0
Sample Output
HOUSE 1 xxxxxxxxxxx x../..\...x x..../....x *../......x x.........x xxxxxx&xxxx HOUSE 2 xxxxx *...& x...x x...x xxxxx HOUSE 3 xxxxx x./\x *./.x x..\& xxxxx HOUSE 4 xxx*xx x/...x x....x x/./.& x\./.x xxxxxx HOUSE 5 xxxxxxxxxx x.../\...x x........x x........x &.../\..\x *...\/../x x........x x........x x...\/...x xxxxxxxxxx
给一张图,其中的/ \ 为镜子,图的外面围着一圈墙,这时候从某个墙射进一束光,问这束光会射到哪块墙上.dfs,在dfs里加入一个光照过来的方向就可以了.往一个方向一直跑,跑到镜子或者墙为止.
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <string>
#include <map>
using namespace std;
int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
char ma[55][55];
int m,n;
int flag;
void dd(int x,int y,int dir)
{
if(ma[x][y]=='x')
{
ma[x][y]='&';
return ;
}
if(dir==1)
{ x+=dx[dir-1];
y+=dy[dir-1];
while(ma[x][y]=='.')
{
x+=dx[dir-1];
y+=dy[dir-1];
}
if(ma[x][y]=='\\')dd(x,y,4);
else if(ma[x][y]=='/')dd(x,y,2);
else if(ma[x][y]=='x')dd(x,y,1);
}
else if(dir==2)
{
x+=dx[dir-1];
y+=dy[dir-1];
while(ma[x][y]=='.')
{
x+=dx[dir-1];
y+=dy[dir-1];
}
if(ma[x][y]=='\\')dd(x,y,3);
else if(ma[x][y]=='/')dd(x,y,1);
else if(ma[x][y]=='x')dd(x,y,1);
}
else if(dir==3)
{ x+=dx[dir-1];
y+=dy[dir-1];
while(ma[x][y]=='.')
{
x+=dx[dir-1];
y+=dy[dir-1];
}
if(ma[x][y]=='\\')dd(x,y,2);
else if(ma[x][y]=='/')dd(x,y,4);
else if(ma[x][y]=='x')dd(x,y,1);
}
else if(dir==4)
{ x+=dx[dir-1];
y+=dy[dir-1];
while(ma[x][y]=='.')
{
x+=dx[dir-1];
y+=dy[dir-1];
}
if(ma[x][y]=='\\')dd(x,y,1);
else if(ma[x][y]=='/')dd(x,y,3);
else if(ma[x][y]=='x')dd(x,y,1);
}
}
int main()
{
int cs=0;
while(cin>>m>>n)
{
if(m+n==0)break;
flag=0;
int i,j;
for(i=0;i<n;i++)
scanf("%s",&ma[i]);
cout<<"HOUSE "<<++cs<<endl;
//for(i=1;i<=n;i++)
//cout<<ma[i]<<endl;
int sx,sy;
int ex,ey;
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
if(ma[i][j]=='*')
{
sx=i;sy=j;
}
}
//cout<<sx<<sy<<endl;
if(sx==0)
{
dd(sx,sy,3);
for(i=0;i<n;i++)
cout<<ma[i]<<endl;
}
if(sx==n-1)
{
dd(sx,sy,1);
for(i=0;i<n;i++)
cout<<ma[i]<<endl;
}
if(sy==0)
{
dd(sx,sy,2);
for(i=0;i<n;i++)
cout<<ma[i]<<endl;
}
if(sy==m-1)
{
dd(sx,sy,4);
for(i=0;i<n;i++)
cout<<ma[i]<<endl;
}
}
return 0;
}