Robot Motion
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9630 Accepted Submission(s): 4458
Problem Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are
N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)
For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.
Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.
You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
Sample Input
3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
Sample Output
10 step(s) to exit 3 step(s) before a loop of 8 step(s)
题目大意是, 输入 i , j 列 ,以及初始位置 , 按照 字母要求走出 矩阵(需要的步数),或者达到循环时 (从开始到循环点的步数以及循环的步数)。
这道题刚开始觉得不难,其实要计算有循环的还是有点难度的。
#include<stdio.h>
int main()
{
int ci,cj,cn;
int i,j,cont;
char c[10][10];
bool flag;
while(scanf("%d%d%d",&ci,&cj,&cn) && ci || cj || cn)
{
int count[10][10] = {0};
for (i = 0; i < ci; i++)
{
scanf("%s",c[i]);
}
cont = 0;
i = 0; //初始位置
j = cn - 1; //初始位置
flag = false;
while (i >= 0 && i < ci && j >= 0 && j < cj)
{
if(count[i][j]){ flag = true;break;} //if 判断 当count[i][j]不再为 0 时,表示不再是第一次到达 c[i][j] 这个字符,
count[i][j] = ++cont; //count[i][j]记录到达 i 行 j 列时走过的步数
if(c[i][j]=='E') j++;
else if(c[i][j]=='W') j--;
else if(c[i][j]=='N') i--;
else if(c[i][j]=='S')i++;
}
if(flag) printf("%d step(s) before a loop of %d step(s)\n",count[i][j] - 1,cont - count[i][j] + 1);
else printf("%d step(s) to exit\n",cont);
}
return 0;
}