杭电ACM 1982 运用映射来做

Kaitou Kid - The Phantom Thief (1)

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2931    Accepted Submission(s): 1280


Problem Description
Do you know Kaitou Kid? In the legend, Kaitou Kid is a master of disguise, and can take on the voice and form of anyone. He is not an evil person, but he is on the wrong side of the law. He's the very elusive phantom thief who never miss his prey although he always uses word puzzles to announce his targets before action.



You are the leader of a museum. Recently, you get several priceless jewels and plan to hold an exhibition. But at the moment, you receive Kid's word puzzle... Fortunately, It seems Kid doesn’t want to trouble you, and his puzzle is very easy. Just a few minutes, You have found the way to solve the puzzle:

(1) change 1 to 'A', 2 TO 'B',..,26 TO 'Z'
(2) change '#' to a blank
(3) ignore the '-' symbol, it just used to separate the numbers in the puzzle
 

Input
The first line of the input contains an integer C which means the number of test cases. Then C lines follow. Each line is a sentence of Kid’s word puzzle which is consisted of '0' ~ '9' , '-' and '#'. The length of each sentence is no longer than 10000.
 

Output
For each case, output the translated text.
 

Sample Input
  
  
4 9#23-9-12-12#19-20-5-1-12#1-20#12-5-1-19-20#15-14-5#10-5-23-5-12 1-14-4#12-5-1-22-5#20-8-5#13-21-19-5-21-13#9-14#20#13-9-14-21-20-5-19 1-6-20-5-18#20-8-5#15-16-5-14-9-14-7#15-6#20-8-5#5-24-8-9-2-9-20-9-15-14 7-15-15-4#12-21-3-11
 

Sample Output
  
  
I WILL STEAL AT LEAST ONE JEWEL AND LEAVE THE MUSEUM IN T MINUTES AFTER THE OPENING OF THE EXHIBITION GOOD LUCK
 

解题思路:有题意可知9--英文字母第九个“I”,23--对应“W”,,,可以想到用映射来解决这个问题。但是这里需要注意的是像23它并不是一个字符而是占了两个字符,对此我给出的方案是下面代码的红色代码。

此外要特别注意下面的紫色代码,不能缺少i++,如果少了i++,像23中的3就会多读一次。

#include<iostream>
#include<string>
using namespace std;
char s[27] = {'0','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
int main()
{
    int n,sum;
    string str;
    while(cin>>n)
    {
        while(n--)
        {
            cin>>str;
            for (int i = 0; i < str.length(); i++)
            {
                if(str[i] == '#') cout<<" ";
                else if(str[i] == '-') continue;
                else 
                {
                    if(str[i + 1] >= '0' && str[i + 1] <= '9')
                    {
                        <span style="color:#cc0000;">sum = 10 * (str[i] - '0') + str[i + 1] - '0';</span>
                        cout<<s[sum];
                        <span style="color:#993399;">i++;</span>
                    }
                    else cout<<s[str[i] - '0'];
                }
            }
            cout<<endl;
        }
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值