FZU 2039 二分图

Description

Are you interested in pets? There is a very famous pets shop in the center of the ACM city. There are totally m pets in the shop, numbered from 1 to m. One day, there are n customers in the shop, which are numbered from 1 to n. In order to sell pets to as more customers as possible, each customer is just allowed to buy at most one pet. Now, your task is to help the manager to sell as more pets as possible. Every customer would not buy the pets he/she is not interested in it, and every customer would like to buy one pet that he/she is interested in if possible.

Input

There is a single integer T in the first line of the test data indicating that there are T(T≤100) test cases. In the first line of each test case, there are three numbers n, m(0≤n,m≤100) and e(0≤e≤n*m). Here, n and m represent the number of customers and the number of pets respectively.

In the following e lines of each test case, there are two integers x(1≤x≤n), y(1≤y≤m) indicating that customer x is not interested in pet y, such that x would not buy y.

Output

For each test case, print a line containing the test case number (beginning with 1) and the maximum number of pets that can be sold out.

Sample Input

12 2 21 22 1

Sample Output

Case 1: 2
题意:
N个人M个宠物e个条件,每个条件告诉你哪些人不喜欢哪些宠物,每个人最多买一条宠物,问最多能有多少人买到宠物?
解题思路:
二分图,寻找增广路,匈牙利算法。
代码:
#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<vector>
using namespace std;
const int maxn=2*105;
const int maxm=2*105*105;
const int INF=0x3f3f3f3f;
int fir[maxn];
int u[maxm],v[maxm],nex[maxm];
int e_max;
int match[maxn];
bool check[maxn];
int g[maxn][maxn];
int ans;
inline void init()
{
         memset(fir, -1, sizeof fir);
         e_max = 0;
}
inline void add_edge(int s, int t)
 {
        int e = e_max++;
        u[e] = s;
        v[e] = t;
        nex[e] = fir[u[e]];
        fir[u[e]] = e;
}
int n,m,e;
bool dfs(int u)
{
        for(int e=fir[u];~e;e=nex[e])
        {
                int vv=v[e];
                if(!check[vv])//访问未访问的节点
                {
                        check[vv]=1;
                        if(match[vv]==-1||dfs(match[vv]))//找到增广,交换这条路的匹配方式,标记。
                        {
                                match[vv]=u;
                                match[u]=vv;
                                return 1;
                        }
                }
        }
        return 0;
}
int  hungary()
{
        ans=0;
        memset(match,-1,sizeof match);
        for(int i=1;i<=n;i++)
        {
                if(match[i]==-1)
                {
                        memset(check,0,sizeof check);//每次初始化check。
                        if(dfs(i))                   //存在增广路(i节点存在匹配)
                                ans++;
                }
        }
}
int main()
{
        int T;
        cin>>T;
        int a,b;
        int w=0;
        while(T--)
        {
                init();
                memset(g,1,sizeof g);
                scanf("%d%d%d",&n,&m,&e);
                for(int i=0;i<e;i++)
                {
                        scanf("%d%d",&a,&b);
                        g[a][b+n]=0;           //把宠物编号为m+1到m+n;
                        g[b+n][a]=0;

                }
                for(int i=1;i<=n;i++)
                {
                        for(int j=n+1;j<=m+n;j++)
                        {
                                if(g[i][j])
                                {
                                        add_edge(i,j);
                                        add_edge(j,i);
                                }
                        }
                }
                hungary();
                printf("Case %d: %d\n",++w,ans);
        }

}


**描述:“适用于JDK8的环境”** 本文将深入探讨Neo4j社区版3.5.6版本,这是一个基于图数据库的强大工具,特别适用于知识图谱构建和可视化。由于其运行需求,必须在Java Development Kit(JDK)8的环境下进行安装和操作。 **一、Neo4j概述** Neo4j是一款开源的图形数据库,它以节点、关系和属性的形式存储数据,这使得处理复杂网络结构的数据变得更为直观和高效。Neo4j社区版是免费的,适合开发和学习用途,而企业版则提供了更多的高级功能和服务。 **二、JDK8要求** 为了运行Neo4j 3.5.6,你需要在你的计算机上安装JDK8。JDK是Java开发工具包,包含了运行Java应用程序所需的Java虚拟机(JVM)以及一系列开发工具。确保安装的是与Neo4j版本兼容的JDK版本至关重要,因为不兼容的JDK可能会导致运行错误或性能问题。 **三、安装和配置** 1. **下载与解压**: 从官方渠道下载"neo4j-community-3.5.6.zip"压缩文件,并将其解压到你选择的目录。 2. **环境变量配置**: 配置系统环境变量,将Neo4j的bin目录添加到PATH环境变量中,以便于命令行启动和管理数据库。 3. **修改配置文件**: Neo4j的配置主要通过`conf/neo4j.conf`文件进行,如需更改默认设置,如内存分配、端口设置等,应在此文件中进行修改。 4. **启动和停止**: 使用`neo4j console`命令启动服务,`neo4j stop`命令关闭服务。 **四、知识图谱与可视化** Neo4j因其强大的图数据模型,成为构建知识图谱的理想选择。你可以使用Cypher查询语言来操作和查询图数据,它的语法简洁且直观,易于学习。 1. **Cypher语言**: Cypher是一种声明式、图形化
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值