To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C
- C Programming Language, M
- Mathematics (Calculus or Linear Algrbra), and E
- English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C
, M
, E
and A
- Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C
, M
and E
. Then there are M lines, each containing a student ID.
Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A
> C
> M
> E
. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A
.
Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A
作者
这道题做了两次了,这次还是不会,诶,太挫败了,但还得加油啊,问题在于怎么排序呢,排序后又该怎么存储,因为对于相同的名次,还要按照规定的学科次序来输出,而学科次序已经是确定了,所以是比较简单的,就算没有确定呢,我们也可以通过改变输入顺序来确定,
难点在于排序,每个都要派,又该怎么存储?,这里就得用二维数组了,可惜我的脑子实在想不出来,真的太菜了,用二位数字来存储四个成绩不就行了呗
#include<bits/stdc++.h>
using namespace std;
struct node
{
int id;
int grade[4];
};
int now;
int course[1001000][4]={0};
char test[4]={'A','C','M','E'};
bool cmp(node a,node b)
{
return a.grade[now]>b.grade[now];
}
int main()
{
int n,m;
cin>>n>>m;
node a[n];
for(int i=0;i<n;i++){
cin>>a[i].id>>a[i].grade[1]>>a[i].grade[2]>>a[i].grade[3];
a[i].grade[0]=(a[i].grade[1]+a[i].grade[2]+a[i].grade[3])/3+0.5;
}
for(now=0;now<4;now++){
sort(a,a+n,cmp);
course[a[0].id][now]=1;
for(int i=0;i<n;i++){
if(a[i].grade[now]==a[i-1].grade[now]){
course[a[i].id][now]=course[a[i-1].id][now];
}
else
course[a[i].id][now]=i+1;
}
}
int query;
for(int i=0;i<m;i++){
cin>>query;
if(course[query][0]==0){
printf("N/A\n");
}
else{
int k=0;
for(int j=1;j<4;j++){
if(course[query][j]<course[query][k]){
k=j;
}
}
cout<<course[query][k]<<" "<<test[k]<<endl;
}
}
}