1443. Printer Queue

【题目要求】

Constraints


Time Limit: 1 secs, Memory Limit: 32 MB


Description


The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 


Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.


The first job J in queue is taken from the queue.
If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 


Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.
Input


One line with a positive integer: the number of test cases (at most 100). Then for each test case:


One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.
Output


For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.


Sample Input


3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1
Sample Output


1
2
5


【解题思路】

本题的点睛之笔在于队列的操作。选择一种容器,来盛放这些作业的优先级。

该容器所容许的操作有:

        允许对任意位置的元素进行访问。

       能对首尾端进行删除添加的操作。

然后选择合适的容器后再依次对队首的元素进行判断,按照既定的方案,若后面有优先级比队首高,则将队首至于队尾。

【遇到的问题】

1.容器选择困难

必须服从方便、减少资源消耗的原则来进行选择。一开始未明确对容器的具体要求。使用了数组、串、list、队列、双端队列,都觉得不合适。最后选择了vector,系统资源占用少,最后的时间和资源占用也很满意

2.初始化问题

由于只建了一个vector,而有多组测试数据,所以出现了前一组数据影响后一组数据。最后加上了vec.clear() - 清空所有元素。

【源代码】

#include<iostream>
#include<vector>
using namespace std;
int main()
{
    vector<int> v;
    int caseNum =0;
    cin>>caseNum;
    while(caseNum>0)
    {
          v.clear();
          caseNum--;
          int n =0,m=0;
          cin>>n>>m;
          for (int i=0;i<n;i++)
          {
              int temp = 0;
              cin>>temp;
              v.push_back(temp);            
          }
          /*
          for (int i=0;i<n;i++)
          {
              cout<<v[i]<<endl;            
          }
          */
          int time = 0;
          for(;;) //依次打印 
          {
                  bool ifPrint = 0;
                  for(int j=0;j<v.size();j++)
                  {
                          if(v[j]>v[0])
                          {                                 
                               if(m == 0)
                               {
                                       m = v.size()-1;
                               }
                               else { m = m-1;}
                               v.push_back(v[0]);
                               v.erase(v.begin());
                               break;
                               
                          }
                          else if(j == v.size()-1)
                          {
                              v.erase(v.begin());
                              time = time +1;
                              if(m == 0)
                              {
                                   cout<<time<<endl;
                                   ifPrint = 1;
                                   break;    
                              }
                              else{ m = m-1;}
                          }                         
                  } 
                  if(v.empty() || ifPrint == true )break;
          } 
    }  
      
    return 0;
}                                 

       



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值