字符串3

Count the string

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 3
Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 


 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 


 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 


 

Sample Input
  
  
1 4 abab
 


 

Sample Output
  
  
6
 


 

Author
foreverlin@HNU
 


 

Source
HDOJ Monthly Contest – 2010.03.06
 


 

题意:给出一个字符串,问包含所有前缀的个数。

思路:kmp算法中的next数组的运用加dp的思想吧。

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char str[200005];
int next[200005];
int dp[200005];//dp[i]表示以str[i]结尾的所包含子串的个数。
//next[i]表示以str[i]结尾的后缀与前缀的匹配的最大个数。
void getNext(char *b,int m)
{
    int tmp=0;
    memset(next,0,sizeof(next));
    for(int i=1;i<m;i++)
    {
        int tmp=next[i-1];
        while(tmp&&b[tmp]!=b[i])
        tmp=next[tmp-1];
        if(b[tmp]==b[i])
        next[i]=tmp+1;
        else
        next[i]=0;
    }
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        getchar();
        for(int i=0;i<n;i++)
        scanf("%c",&str[i]);
        getNext(str,n);
        for(int i=1;i<=n;i++)
        {
            dp[i]=dp[next[i-1]]+1;//因为以上次匹配位置i到本次之间的字符j为结尾的字符串不能匹配
                                  //否则next[j]!=i;应该会是i到j之间的数。
            sum=(sum+dp[i])%10007;
        }
        printf("%d\n",sum);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值