poj 2386 Lake Counting 水水的搜索模板

题目啊:
Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34736 Accepted: 17247
Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.
Sample Output

3

贴广搜代码不解释=.=

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int map[110][110], x[9]={0,0,1,0,-1,1,-1,1,-1},
    team[10000][3],y[9]={0,1,0,-1,0,1,1,-1,-1},
    n,m,ans;
bool map1[110][110];
char a;

void bfs(int a,int b)
{
    memset(team,0,sizeof(team));
    int h=0,t=1;
    team[1][1]=a,team[1][2]=b,map1[a][b]=1;
    do
    {
        h++;
        for(int i=1;i<=8;i++)
        {
            int xx,yy;
            xx=team[h][1]+x[i];
            yy=team[h][2]+y[i];
            if(map[xx][yy]&&!map1[xx][yy])
            {
                map1[xx][yy]=1;
                map [xx][yy]=0;
                t++;
                team[t][1]=xx;
                team[t][2]=yy;
            }
        }
    }while(h<t);
}

int main()
{
//  freopen("in.txt","r",stdin);
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        getchar();
        for(int j=1;j<=m;j++)
        {
            scanf("%c",&a);
            if(a=='W')
                map[i][j]=1;
            else map[i][j]=0;
        }
    }

    for(int i=1;i<=n;i++)
    for(int j=1;j<=m;j++)
    {
        if(map[i][j])
        {
            bfs(i,j);
            ans++;
        }
    }

    printf("%d",ans);
}

果然要时不时练练手=.=||

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值