POJ #2586 Y2K Accounting Bug

该博客讨论了一个编程问题,涉及如何确定MS公司在1999年是否出现亏损,或者如果可能,计算最大的盈余金额。问题设置中,公司每个月要么盈余`s`,要么亏损`d`,并且每连续5个月报告一次亏损。给定每年8次亏损报告,程序需要找出可能的最大盈余或确认亏损。解决方案包括检查四种亏损情况,并计算对应的最大盈余。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

原题地址

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.
Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input
Input is a sequence of lines, each containing two positive integers s and d.
Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000
Sample Output
116
28
300612
Deficit

题目意思:ACM会计丢失了1999MS公司年度报告数据,他们每连着五个月会进行一次盈亏报告(12345,23456~~),每个月盈利是s(surplus),亏本是d(deficit),ACM不知道他们每个月的s或d,但ACM知道他们8次报告都是亏本,请写出程序看MS公司这一年是否亏本,或者有可能盈利的最大盈利。

输入: 多行输入,每行两个正整数,一个月的 s d (盈利,亏本)。
输出:每行输出一个数,表示一年可能的最大盈利量,或者亏本,则输出Deficit。

思路:盈利为s,亏本为d
则有四种情况
1:五个月亏四次—dddds,则一年为 dddds dddds dd, 共2次s,10次d
2:五个月亏三次—dddss,则一年为 dddss dddss dd;共4次s,8次d
3:五个月亏二次—ddsss,则一年为 ddsss ddsss dd;共6次s,6次d
4:五个月亏一次—dssss,则一年为 dssss dssss ds;共9次s,3次d

从下至上进行判断(从s最多开始,因为要算出最大盈利),算出五个月是否亏损
即判断 (5-x)s-xd<0?,若满足,则一年最大盈利=总的s-总的d,若都不满足则Deficit

AC代码:

#include <stdio.h>

int main()
{
    long long s,d,x,y,sum;
    while(~scanf("%lld%lld",&s,&d))
    {   sum=-1;	//初始化,若不满足条件则可判断
        for(x=1; x<=4; x++)	//x表示五个月中亏损的次数
        {
            if((5-x)*s-x*d<0)	//判断五个月是否亏损
            {
                if(x==4)				//4个月时单独分开因为d出现规律不同
                    sum=3*s-9*d;	//总盈利
                else
                sum=(12-2*x)*s-2*x*d;	//总盈利
                if(sum>=0)		//总盈利>0后退出循环
                    break;
            }
        }
        if(sum>=0)		//输出
            printf("%lld\n",sum);
        else
            printf("Deficit\n");
    }
}

题目有点难懂,懂了就是水题

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值