浙大大学 PTA 单链表结点删除


6-6 单链表结点删除 (20 point(s))


本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中所有存储了某给定值的结点删除。链表结点定义如下:
struct ListNode {
int data;
ListNode *next;
};
函数接口定义:

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deletem将单链表L中所有存储了m的结点删除。返回指向结果链表头结点的指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
void printlist( struct ListNode *L )
{
struct ListNode *p = L;
while § {
printf("%d “, p->data);
p = p->next;
}
printf(”\n");
}

int main()
{
int m;
struct ListNode *L = readlist();
scanf("%d", &m);
L = deletem(L, m);
printlist(L);

return 0;

}

/* 你的代码将被嵌在这里 */
输入样例:

10 11 10 12 10 -1
10
输出样例:

11 12
Author
张泳
Organization
浙大城市学院
Code Size Limit
16 KB
Time Limit
400 ms
Memory Limit
64 MB

struct ListNode *readlist()
{
    struct ListNode *p = (struct ListNode*)malloc(sizeof(struct ListNode));
    struct ListNode *q = p, *head = p;
    int num;
    scanf("%d", &num);
    while (num != -1) {
        p->data = num;
        q = p;
        p = (struct ListNode*)malloc(sizeof(struct ListNode));
        q->next = p;
        scanf("%d", &num);
    }
    if(q != NULL)//记得加上,不然可能会段错误,当q==NULL时,再用q->next就无意义了
        q->next = NULL;
    return head;
}

struct ListNode *deletem( struct ListNode *L, int m )
{/***********虚拟头节点法**************/
    struct ListNode *slow, *fast = L;
    struct ListNode *dummyHead = (struct ListNode *)malloc(sizeof(struct ListNode));
    dummyHead->next = L;
    slow = dummyHead;
    while (fast != NULL){
        if (fast->data == m){
            slow->next = fast->next;
        }
        else
            slow = slow->next;
        fast = fast->next;
    }
    return dummyHead->next;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值