PAT 1023 Have Fun with Numbers (20)

1023 Have Fun with Numbers (20)(20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路:

因为N最多有20位,所以int肯定不够,用了字符串。从串尾开始每一位都乘2,然后对应位上存乘2结果的个位,对应位的上一位存乘2结果的十位。用一个数组来统计各数字出现的次数,一开始输入时把出现次数统计好,做完乘法后再将出现次数减掉,但凡有一位被减到-1,那就是不符合要求的。还要注意有的数字乘2后会在最高位多一位,也是不符合要求的数。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

int main()
{
	string s;
	int num[10] = { 0 };
	int a[25] = { 0 }, k = 0;
	cin >> s;
	for (int i = 0; i < s.length(); i++)
		num[s[i] - '0']++;
	for (int i = s.length() - 1; i >= 0; i--)
	{
		a[k] += (s[i] - '0') * 2 % 10;
		a[k + 1] = (s[i] - '0') * 2 / 10;
		k++;
	}
	bool flag = true;
	if (a[k] == 0)
	{
		for (int i = 0; i < k; i++)
		{
			num[a[i]]--;
			if (num[a[i]] == -1)
			{
				flag = false;
				break;
			}
		}
		if (flag)
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
		for (int i = k - 1; i >= 0; i--)
			cout << a[i];
	}
	else
	{
		cout << "No" << endl;
		for (int i = k; i >= 0; i--)
			cout << a[i];
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值