Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, ...
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.
Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.
Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.
Sample Input:
1 8
Sample Output:
1123123111
思路
模拟题
cpp代码
// 1 11 12 1121 122111 112213 12221131 1123123111
#include<iostream>
#include<vector>
using namespace std;
int main(){
int n,m;
cin>>n>>m;
string s=to_string(n);
if(m==1){ cout<<s<<endl;return 0;}
while(m--){
vector<int>vec,count;
int j=0;
for(int i=0;i<s.size();){
if(s[i]==s[j])i++;
else count.push_back(i-j),vec.push_back(s[j]-'0'),j=i;
}
vec.push_back(s[j]-'0');
count.push_back(s.size()-j);
string res="";
for(int i=0,j=0;i<vec.size();i++,j++){
res+=to_string(vec[i])+to_string(count[j]);
}
if(m==1){ cout<<res<<endl;return 0;}
s=res;
}
return 0;
}