1155 Heap Paths

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input:

8
98 72 86 60 65 12 23 50

Sample Output:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

思路

就是先给我们一个堆的层序遍历,让我们判断是不是大小根堆或者不是堆,然后输出dfs输出从根节点到叶子节点的路径即可
判断是不是大小根堆或者不是堆可以现将层序遍历存到一维数组里,因为堆很像一颗完全二叉树,因此就有u是根节点,2u是左孩子,2u+1是右孩子这样的操作。遍历一维数组,如果存在一个祖宗节点的值大于孩子节点的值,就不是小根堆,如果存在一个祖宗节点的值小于孩子节点的值,就不是大根堆。

cpp代码

#include<iostream>
using namespace std;
const int N=1010;
int p[N];
int n;
int dep[N];
void dfs(int u,int deep){
    dep[deep]=p[u];
    if(2*u>n&&2*u+1>n){//说明已经到叶子节点了
        cout<<dep[0];
        for(int i=1;i<=deep;i++){
            cout<<" "<<dep[i];
        }
        puts("");
        return ;
    }

    if(2*u+1<=n)dfs(2*u+1,deep+1);
    if(2*u<=n)dfs(2*u,deep+1);

}
int main(){
    cin>>n;
    for(int i=1;i<=n;i++)cin>>p[i];
    int ismax=1;
    int ismin=1;
    for(int i=2;i<=n;i++){
        if(p[i]>p[i/2])ismax=0;
        if(p[i]<p[i/2])ismin=0;
    }

    dfs(1,0);

    if(ismax)puts("Max Heap");
    if(ismin)puts("Min Heap");
    if(!ismax&&!ismin)puts("Not Heap");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值