题目链接hud2594
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
Sample Input
clinton
homer
riemann
marjorie
Sample Output
0
rie 3
利用strcat将2个字符串合并为一个字符串,然后利用next数组求公共前后缀
注意(aaaa与a 和a与aaaa这两种情况)
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define N 200000
using namespace std;
char str1[N],str2[N];
int Next[N];
void getnext(char *s,int slen)
{
Next[0]=0;Next[1]=0;
for(int i=1;i<slen;i++)
{
int j=Next[i];
while(j&&s[i]!=s[j]) j=Next[j];
Next[i+1] = (s[i]==s[j])?j+1:0;
}
}
int main()
{
while(~scanf("%s%s",&str1,&str2))
{
memset(Next,0,sizeof(Next));
char str3[N];
memset(str3,'\0',sizeof(str3));
strcat(str3,str1);
strcat(str3,str2);
int slen = strlen(str3);
int slen1 = strlen(str1);
int slen2 = strlen(str2);
getnext(str3,slen);
int k = Next[slen];
if(k==0) {
cout<<0<<endl;
}
if(k>=slen1)
{
// cout<<slen1<<endl;
//cout<<slen2<<endl;
if(slen1<=slen2)
{ //cout<<1113333333311111<<endl;
for(int i=0;i<slen1;i++)
{
cout<<str1[i];
}
cout<<" "<<slen1<<endl;
}
if(slen2<slen1)
{
//cout<<11111111<<endl;
for(int i=0;i<slen2;i++)
{
cout<<str2[i];
}
cout<<" "<<slen2<<endl;
}
}
if(k<slen1&&k>0)
{
for(int i=0;i<k;i++)
cout<<str3[i];
cout<<" "<<k<<endl;
}
}
}