Simpsons’ Hidden Talents(求两个字符串的公共前后缀)

该博客探讨了一个程序设计问题,涉及寻找两个字符串之间的最长公共前后缀。通过使用字符串连接和next数组来实现,重点在于理解字符串操作和算法的应用。示例中,Homer试图找出自己名字与政治家名字之间的关联,而Marge则发现了她的名字与数学家名字的有趣巧合。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接hud2594

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie
Sample Output
0
rie 3

利用strcat将2个字符串合并为一个字符串,然后利用next数组求公共前后缀
注意(aaaa与a 和a与aaaa这两种情况)

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define N 200000
using namespace std;
char str1[N],str2[N];
int Next[N];
void getnext(char *s,int slen)
{
	Next[0]=0;Next[1]=0;
	for(int i=1;i<slen;i++)
	{
		int j=Next[i];
		while(j&&s[i]!=s[j]) j=Next[j];
		Next[i+1] = (s[i]==s[j])?j+1:0; 
	}
	
}


int main()
{
	while(~scanf("%s%s",&str1,&str2))
	{
		memset(Next,0,sizeof(Next));
		char str3[N];
		memset(str3,'\0',sizeof(str3));
		strcat(str3,str1);
		strcat(str3,str2);
		int slen = strlen(str3);
		int slen1 = strlen(str1);
		int slen2 = strlen(str2);
		
		getnext(str3,slen);
		int k = Next[slen];
		if(k==0) {
			cout<<0<<endl;
			
		}
		if(k>=slen1)
		{
		//	cout<<slen1<<endl;
			//cout<<slen2<<endl;
				
			if(slen1<=slen2)
			{	//cout<<1113333333311111<<endl;
				for(int i=0;i<slen1;i++)
				{
					cout<<str1[i];
					
				}
				cout<<" "<<slen1<<endl;
			}
			if(slen2<slen1)
			{
				//cout<<11111111<<endl;
			for(int i=0;i<slen2;i++)
				{
					cout<<str2[i];
					
				}
				cout<<" "<<slen2<<endl;
			}
		}
		if(k<slen1&&k>0)
		{
			for(int i=0;i<k;i++)
				cout<<str3[i];
			cout<<" "<<k<<endl;
		}
		
	
		
		
	}
	

	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值