E-POJ-3087 Shuffle‘m Up 模拟

该博客探讨了一种常见的扑克牌洗牌方法,即通过交错两堆芯片来混合颜色。它给出了一种算法实现,用于确定能否通过一定次数的洗牌操作将两堆初始芯片序列变为目标序列,并给出了C++代码示例。博客中还提到,如果在洗牌过程中回到了初始状态,那么就无法达到目标序列。最后,博主分享了如何计算最少的洗牌次数,并提供了若干测试用例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Shuffle’m Up
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21491 Accepted: 9677
Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:
在这里插入图片描述

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC
Sample Output

1 2
2 -1

模拟

题意:给你两个字符串,看能不能根据规则弄成第3个字符串的,可以的话输出操作数,**分牌时不计算操作数。**详细见代码
注意:如果洗牌洗回初始状态,还没找到就找不到了,跳出循环。

#include "iostream"
#include "string"
using namespace std;
int main()
{
	int T;
	cin>>T;
	for(int q=1;q<=T;q++)//将q当作第几次样例
	{
		string a,b,c,d,e,ss;
		int len;
		cin>>len;
		cin>>a>>b>>ss;
		d=a,e=b;//保存初始状态
		int flag=0,flaggg=0;
		int index=1;//变换洗牌还是分牌
		while(1)
		{
			
			if(index)
			{
				c.clear();//注意清空
				flag++;//操作数
				for(int i=0;i<len;i++)//洗牌规则
				{
					c+=b[i];
					c+=a[i];
				}
				if(c==ss)//洗对了
				{
					flaggg=1;
					break;
				}
				index=0;
			}
			else
			{
				a.clear();
				b.clear();
				for(int i=0;i<2*len;i++)
				{
					if(i<len)
					{
						a+=c[i];
					}
					else
					{
						b+=c[i];
					}
				}
				if(a==d&&b==e)//回到初始状态
				{
					break;
				}
				index=1;
			}
		}
		if(flaggg)
		{
			cout<<q<<" "<<flag<<endl;
		}
		else
		{
			cout<<q<<" -1"<<endl;
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值