要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2 1000 53 87 123456789
Sample Output
7922 6060
板子题,把扩展欧几里得放上就行。
//#include <bits/stdc++.h>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
typedef long long ll;
const int maxn=105;
ll exgcd(ll a,ll b,ll &x,ll &y)
{
if(b==0)
{
x=1,y=0;
return a;
}
ll r=exgcd(b,a%b,x,y);
ll tmp=y;
y=x-(a/b)*y;
x=tmp;
return r;
}
int main()
{
// freopen("input.txt","r",stdin);
int t;
cin>>t;
while(t--)
{
ll n,B;
cin>>n>>B;
ll x,y;
exgcd(B,9973,x,y);
printf("%lld\n",n*(x+9973)%9973);
}
return 0;
}