PAT甲级1019

根据输入的十进制数N和基数b,确定N是否为b进制下的回文数。回文数是指正读反读都一样的数。输出结果为Yes或No,并以指定进制显示N的值。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1019 General Palindromic Number (20 point(s))

  A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
  Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i as ∑k​i=0​​ (a​ib​i). Here, as usual, 0≤a​i<b for all i and a​k is non-zero. Then N is palindromic if and only if a​i = a​k−i for all i. Zero is written 0 in any base and is also palindromic by definition.
  Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9 is the decimal number and 2≤b≤10​9 is the base. The numbers are separated by a space.

Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “a​ka​k−1​​ … a​0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题目大意

  给定一个十进制数以及进制,判断这个数在该进制下是否为回文数

解题思路

  先把十进制数转化为给定进制数,再判断是否为回文数即可。若是,输入Yes,否则输出No,最后再输出该数

代码

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>

bool isPalind(int a[], int n) {
	int i = 0, j = n - 1;
	while (i < j) {
		if (a[i] != a[j]) {
			return false;
		}
		++i;
		--j;
	}
	return true;
}

int main() 
{
	int N, b;
	int ret = scanf("%d %d", &N, &b);
	int N_b[1000] = { 0 }, n = 0;
	while (N) {
		N_b[n++] = N % b;
		N /= b;
	}
	if (isPalind(N_b, n)) printf("Yes\n");
	else printf("No\n");
	for (int i = n - 1; i >= 0; --i) {
		if (i != n - 1) printf(" ");
		printf("%d", N_b[i]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值