PAT甲级 1051 Pop Sequence (25 分)

本文讲解了如何通过模拟栈的数据结构,判断给定的长度为N的序列是否可以作为栈中按顺序1到N入栈并随机出栈得到的合法pop序列。利用预设值pre跟踪上一次入栈数,通过一系列条件判断,确保栈操作的可行性。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

结尾无空行

Sample Output:

YES
NO
NO
YES
NO

结尾无空行

思路:模拟栈,pre记录上次压入栈中的值的下个元素,一直压栈直到
栈顶元素等于给出的序列的当前值,若此时栈的大小大于给定大小则不可能,
否则一直出栈直到栈顶元素不等于给定序列的当前值。若此时栈顶元素大于
数组元素则不可能(从小到大入栈,随机出栈,栈顶元素必定栈内最大)

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int m,n,k;
    scanf("%d %d %d",&m,&n,&k);
    for(int i=0;i<k;i++)
    {
        vector<int> temp(n);
        stack<int> st;
        for(int j=0;j<n;j++) scanf("%d",&temp[j]);
        int pos=0,pre=1;
        bool flag=true;
        while(pos<temp.size())
        {
            for(int i=pre;i<=temp[pos];i++) st.push(i);
            if(!st.empty()) pre=st.top()+1;
            if(st.size()>m)
            {
                flag=false;
                break;
            }
            if(!st.empty())
            {
                while((!st.empty())&&(pos<temp.size())&&(st.top()==temp[pos]))
                {
                    st.pop();
                    pos++;
                }
                if(!st.empty()&&st.top()>temp[pos])
                {
                    flag=false;
                    break;
                }
                continue;
            }
            pos++;
        }
        if(!st.empty()||flag==false) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值