1076 Forwards on Weibo (Life is so fucking hard, bring a brother to tears)

本文介绍了一个基于社交网络的算法,用于计算微博用户在特定层级间接关注者中可能触发的最大转发量。通过广度优先搜索算法,考虑到每个用户可以查看并转发初始帖子一次,算法能够估算出用户在限定层级内的影响力。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
int n,l,m,k,tid;
vector<int>v[1001];
struct node
{
    int id,layer;
};
int bfs(node tnode)
{
    queue<node>q;
    int visited[1001]={0};
    visited[tnode.id]=1;
    int cnt=0;
    q.push(tnode);
    while(!q.empty())
    {
        node top=q.front();
        q.pop();
        int topid=top.id;
        for(int i=0;i<v[topid].size();i++)
        {
            int nextid=v[topid][i];
            if(visited[nextid]==0&&top.layer<l)
            {
                node next={nextid,top.layer+1};
                q.push(next);
                visited[next.id]=1;
                cnt++;
            }
        }
    }
    return cnt;
}
int main()
{
    cin>>n>>l;
    for(int i=1;i<=n;i++)
    {
        cin>>m;
        for(int j=0;j<m;j++)
        {
            int user_list;
            cin>>user_list;
            v[user_list].push_back(i);
        }
    }
    cin>>k;
    for(int i=0;i<k;i++)
    {
        cin>>tid;
        node tnode={tid,0};
        cout<<bfs(tnode)<<endl;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值