适合初步练习PAT乙级——(1054) 求平均值
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
#include<iostream>
#include<vector>
#include<string>
using namespace std;
int main() {
int N, j = 0;
cin >> N;
vector<double>v;
string str;
for (int i = 0; i < N; i++) {
cin >> str;
int count1 = 0, count2 = 0;//count1为统计负数符号“-”的个数,count2为统计小数点的个数
for ( j = 0; j < str.length(); j++) {
if (isdigit(str[j]) || str[j] == '.' || str[j] == '-') {//判断字符中是否只含数字、负号、小数点
if (str[j] == '-')count1++;
if (str[j] == '.')count2++;
if (count1 >= 2 || count2 >= 2) {//最多只能含有一个符号和小数点,否则为不合法数字
cout << "ERROR: " << str << " is not a legal number" << endl;
break;
}
continue;
}
else {
cout << "ERROR: " << str << " is not a legal number" << endl;
break;
}
}
if (j == str.length()) {//通过以上条件
if (stof(str) > 1000 || stof(str) < -1000) {判断是否在-1000到1000之间
cout << "ERROR: " << str << " is not a legal number" << endl;
continue;
}
if (str.find('.') != string::npos&&str.length() - str.find('.') > 3) {//判断最多只有两个小数
cout << "ERROR: " << str << " is not a legal number" << endl;
continue;
}
v.push_back(stof(str));
}
}
double sum = 0;
if (v.size() == 0) cout << "The average of 0 numbers is Undefined";
else if (v.size() == 1) printf("The average of 1 number is %.2f", v[0]);
else {
for (int i = 0; i < v.size(); i++) sum += v[i];
printf("The average of %d numbers is %.2f", v.size(), sum / v.size());
}
return 0;
}
思路:具体思路见代码
C++将string转化为int或者double
转化为int:
string s = “123”;
int c = stoi(s);
将string转化为float:
string s = “123.5”;
float c = stof(s);
将string转化为double:
string s = “123.5”;
float c = stod(s);
本题要注意如何连接各个条件,在开头定义int j=0;然后if (j == str.length())来连接,这样能确保通过上面条件的才能进行下面的条件判断。
另外,值得一提的是,string的长度为str,length();而char s[]的长度为strlen()。
另外,本题不能解决 像.-2这样不合法的输入,但本题的测试样例并没有