POJ1836 Alignment

博客围绕军队士兵排队问题展开,士兵按编号排列但未按身高排列,队长要求部分士兵出列,使剩余士兵能看到队列至少一端。需根据士兵身高确定最少出列人数,给出输入输出要求及示例,还提及使用动态规划解决该问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line’s extremity (left or right). A soldier see an extremity if there isn’t any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.
Input
On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]
Output
The only line of output will contain the number of the soldiers who have to get out of the line.
Sample Input
8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2
Sample Output
4
代码如下:
(动态规划)

#include<cstdio>
#include<algorithm>
using namespace std;
const int L=1010;
int dp1[L],dp2[L];
double arr[L];
int main()
{
    int n,rem=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%f",&arr[i]);
        dp1[i]=1;
        dp2[i]=1;
    }
  //正向最长不下降
     for (int i=1; i <=n; i++)
        {
            for (int t=1;t<i;t++)
                if (arr[i]> arr[t])
                dp1[i] = max(dp1[i], dp1[t]+1);
        }
//反向最长不下降
        for (int i=n;i>0; i--)
        {
            for (int t=n; t>i;t--)
                if (arr[i] > arr[t])
            dp2[i] = max(dp2[i], dp2[t]+1);
        }
  //由左先增至右后减
        for (int i =1;i<n; i++)
        for (int j = i + 1; j<=n; j++)
            rem=max(rem,dp1[i] +dp2[j]);
       printf("%d\n",n-rem);
       return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值