HDU_4883(TIANKENG’s restaurant)

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 3383    Accepted Submission(s): 1271


 

Problem Description

TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?

 

 

Input

The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.

 

 

Output

For each test case, output the minimum number of chair that TIANKENG needs to prepare.

 

 

Sample Input

 

2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00

 

 

Sample Output

 

11 6

思路:

把每时刻需要的板凳数记录下来,求出在一时刻最大的对板凳的需求数量,即为最终所需最少板凳数。

分析:

需要统计每个时刻需要多少个板凳,并求其这些时刻所需板凳的最大值。
在开始到结束这个时间段内,都需要用到板凳,所以那些时刻作为下标所对应的数组元素值都需要加上板凳的数目(不包括结束时间)。
第二次输入的时候,也要进行计算开始的时间(该时间对应的分钟)和结束的时间(该时间对应的分钟),然后再开始和结束的时间内都需要在对应的数组上加上所需板凳的数目;以此类推,直到输入n次为止,这样就可以算出每个时刻所需要的板凳数目,相应比较得出需要板凳最多的时刻所需要的板凳即为最终需要凳子最少数。

AC代码

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn=1440+7;
int sum[maxn];
int main()
{
	int t,n,a,b,c,d,i,begin,end;
     int maxnn,aa,j;
	scanf("%d",&t);
	while(t--)
	{
		memset(sum,0,sizeof(sum));
		scanf("%d",&n);
		maxnn=0;
		for(i=0;i<n;i++)
		{
			scanf("%d %d:%d %d:%d",&aa,&a,&b,&c,&d);
		    begin=a*60+b;
			end=c*60+d;//转化为分钟 
			for(j=begin;j<end;j++)//在开始和结束时间内都需要板凳(结束时间不包括在内) 
			{
				sum[j]+=aa;//这些时刻对应的都需要加上板凳的数目 
				maxnn=(sum[j]>maxnn)?sum[j]:maxnn;//更新maxnn为所需凳子最多的那一时刻所需的凳子 
			}
		}		
		printf("%d\n",maxnn); 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值