In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
int m,n;
vector<int> level,post;
void postOrder(int index){
if(index>=n) return;
postOrder(index*2+1);
postOrder(index*2+2);
printf("%d%s",level[index],index==0?"\n":" ");
}
int main() {
cin>>m>>n;
level.resize(n);
post.resize(n);
for(int i=0;i<m;i++){
for(int j=0;j<n;j++)
cin>>level[j];
int flag=level[0]>level[1]?1:-1;
for(int j=0;j<=(n-1)/2;j++){
int left=j*2+1,right=j*2+2;
if(flag==1&&(level[left]>level[j]||(right<n&&level[right]>level[j]))) flag=0;
if(flag==-1&&(level[left]<level[j]||(right<n&&level[right]<level[j]))) flag=0;
}
if(flag==0) printf("Not Heap\n");
else printf("%s Heap\n",flag==1?"Max":"Min");
postOrder(0);
}
return 0;
}