【题解】poj3321 Apple Tree dfs序+树状数组

这是一道关于苹果树的题目,树上有N个节点,节点间通过树枝连接。Kaka想要知道子树中苹果的数量。题目涉及 dfs序 和 树状数组 的概念,需要处理苹果的增减及查询子树苹果总数的问题。给出的样例输入和输出展示了变化过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接

Description

There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?
这里写图片描述

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2


dfs序裸题

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int N=1e5+10;
int n,m,sum[N<<2],in[N],out[N],id[N],cnt,tot,head[N],vis[N];
struct Edge{
    int v,nx;
}e[N<<1];
inline void addedge(int u,int v)
{
    e[tot].v=v;
    e[tot].nx=head[u];
    head[u]=tot++;
}
void dfs(int u,int fa)
{
    in[u]=++cnt;
    for(int i=head[u];~i;i=e[i].nx)
    {
        int v=e[i].v;
        if(v==fa)continue;
        dfs(v,u);
    }
    out[u]=cnt;
}
inline void add(int p)
{
    int x=vis[p]?-1:1;vis[p]^=1;
    for(;p<=cnt;p+=p&(-p))sum[p]+=x;
}
inline int ask(int p)
{
    int ret=0;
    for(;p;p-=p&(-p))ret+=sum[p];
    return ret;
}
int main()
{
    //freopen("in.txt","r",stdin);
    std::ios::sync_with_stdio(false);
    memset(head,-1,sizeof(head));
    char ch;
    cin>>n;
    int u,v,x;
    for(int i=1;i<n;i++)
    {
        cin>>u>>v;
        addedge(u,v);addedge(v,u);
    }
    dfs(1,0);
    for(int i=1;i<=n;i++)add(in[i]); 
    cin>>m;
    for(int i=1;i<=m;i++)
    {
        cin>>ch>>x;
        if(ch=='Q')cout<<ask(out[x])-ask(in[x]-1)<<endl;
        else add(in[x]);
    }
    return 0;
}

总结

水题

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值