Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤104, the total number of coins) and M (≤102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the face values V1≤V2≤⋯≤Vk such that V1+V2+⋯+Vk=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.
Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].
Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution
思路:这是一个简单的01背包问题+记录路径问题。可以套用背包问题模板,然后使用一个二位数组表示是否选中,从后往前遍历,如果被选择,那么存入vector中,并且把相应的容量减少。
关于背包问题推荐看一下acwing上的背包9讲问题。https://www.acwing.com/problem/
问题2-12,经典的背包9讲问题,题目后面也有详细的视频讲解,值得推荐一下。
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
bool choice[10010][10010] = { false };
bool cmp(int a, int b) {
return a > b;
}
int main() {
int dp[110] = { 0 }, w[10010], n, m;
vector<int > num;
cin >> n >> m;
for (int i = 1; i <= n; i++) {
scanf("%d", &w[i]);
}
sort(w + 1, w + n + 1, cmp);
for (int i = 1; i <= n; i++) {
for (int v = m; v >= w[i]; v--) {
if (dp[v] <= dp[v - w[i]] + w[i]) {
dp[v] = dp[v - w[i]] + w[i];
choice[i][v] = 1;
}
else
choice[i][v] = 0;
}
}
if (dp[m] != m) {
cout << "No Solution" << endl;
return 0;
}
int k = n, v = m;
while (k >= 0) {
if (choice[k][v] == 1) {
num.push_back(w[k]);
v -= w[k];
}
k--;
}
for (int i = 0; i < num.size(); i++) {
if (i != 0)
cout << " ";
cout << num[i];
}
}