pat 1041

博客介绍了火星独特的彩票规则,即从[1,10^4]选号,首个选到唯一数字者获胜。给出输入输出规范及示例,还提供了实现该规则的代码,通过统计各数字出现次数找出获胜数字,若没有则输出None。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10
​4
​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10
​5
​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17
Sample Output 1:

31
Sample Input 2:

5 888 666 666 888 888
Sample Output 2:

None

代码
#include<stdio.h>
int a[100000]={0};
int main()
{
int n;
int x[100000];
int j;
int tmp=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&x[i]);
if(x[i]>tmp)
tmp=x[i];
a[x[i]]++;
}
for(j=0;j<n;j++)
{
if(a[x[j]]1)
{
printf("%d",x[j]);
break;
}
}
if(j
n)
printf(“None”);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值