POJ 1029 False coin

通过一系列称重试验,找出一组硬币中唯一一枚假币的方法。使用简单天平进行多次称重,记录每枚硬币的位置及结果,最终确定哪枚硬币是假的。涉及到的算法包括数据结构和逻辑判断,适用于编程竞赛和算法训练。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

False coin

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22295 Accepted: 6256

Description

The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting:
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan,
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

Sample Output

3

Source

Northeastern Europe 1998

 

思路模拟题,小时候经常玩的找假硬币的题目,只是我菜。。。

 

// 主要思路: 若是=, 那么两边都是true
//            若是<, 那么左边为轻的,右边为重的
//            若是>, 那么左边为重的,右边为轻的
//  判断方法: a. 若一个硬币既出现在过轻的一端也出现在过重的一段,那么为真的
//             b. 已经比较了true的为真的
//             c. 只在一边出现,并且为重或者为轻的次数等于总共发生偏移(即为'<'和'>'情况的)的次数,可能为false
//             d. 若满足c的只有一个硬币那么该硬币就为假货,否则无法判断

#include <cstdio>
#include <string.h>
const int MaxN = 1005;
const int MaxK = 105;
struct node
{
    int heavy,light;        // 分别表示其在重的一端和轻的一端的次数
    bool isTrue;            // 标记是否为真硬币
}coins[MaxN];
int left[MaxN>>1], right[MaxN>>1], N, K, p;


int main()
{
    while(~scanf("%d %d",&N, &K))
    {
        memset(coins, 0, sizeof(coins));
        int op = 0;
        for(int k = 0; k < K; k++)
        {
            scanf("%d", &p);
            for(int i = 0; i < p; i++)    scanf("%d", left+i);
            for(int i = 0; i < p; i++)    scanf("%d", right+i);
            getchar();
            char ch = getchar();
            if(ch == '=')
            {
                for(int i = 0; i < p; i++)
                {
                    coins[left[i]].isTrue=coins[right[i]].isTrue=true;
                }
            }
            else if(ch == '<')
            {
                op++;
                for(int i = 0; i < p; i++)
                {
                    coins[left[i]].light++;
                    coins[right[i]].heavy++;
                }
            }
            else if(ch == '>')
            {
                op++;
                for(int i = 0; i < p; i++)
                {
                    coins[left[i]].heavy++;
                    coins[right[i]].light++;
                }
            }
        }
        int index = 0, cnt = 0;
        for(int i = 1; i <= N; i++)
        {
            if(!coins[i].isTrue && (coins[i].heavy == op ||coins[i].light == op))
            {
                index = i;
                cnt++;
            }
        }
        if(cnt != 1)    printf("0\n");
        else    printf("%d\n", index);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值