1078 Hashing (25 分)
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSizeis the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.
Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
题意:
模拟哈希表开放定址法解决冲突的问题,有位置输出位置,没有位置输出-1
摘抄:
二次探测——
其中,h是哈希寻址函数,key是要存储的值,M是哈希表的大小,一般使用素数可以达到一个较高的效率。
思路:
找到合适的素数,再按照二次探测的写法写,其中测试点2一直过不了,看了其他的博客说是(第二个测试点有两个特例,一个是较大的数据,超过10^4的第一个素数10007,所以要定义较大的数组)后来是改了一下素数判断里的特判1就过了,不知道是为何?
#include<iostream>
#include<vector>
using namespace std;
const int maxn=1000010;
bool vis[maxn]={false};
bool is_prime(int n)
{
if(n==1)return false;//加了这一句第二个测试点就过了
for(int i=2;i*i<=n;i++)
if(n%i==0)
return false;
return true;
}
vector<int>ans;
int main()
{
int msize,n,x;
scanf("%d%d",&msize,&n);
while(is_prime(msize)==false)
msize++;
vector<int>v(msize);
for(int i=0;i<n;i++)
{
int flag=0;
scanf("%d",&x);
int pos;
for(int j=0;j<msize;j++)
{
pos=(x+j*j)%msize;
if(vis[pos]==false)
{
vis[pos]=true;
flag=1;
break;
}
}
if(flag)
ans.push_back(pos);
else
ans.push_back(-1);
}
for(int i=0;i<ans.size();i++)
{
if(ans[i]>=0)
printf("%d",ans[i]);
else if(ans[i]==-1)
printf("-");
if(i<ans.size()-1)
printf(" ");
}
}