POJ-2182 Lost Cows 新思路

解决一个有趣的问题:根据每头牛前面有多少头品牌编号较小的牛来确定它们的正确排序。使用 C++ 和数据结构技巧完成这个挑战。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.
Input
* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
Output
* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
Sample Input
5
1
2
1
0
Sample Output
2
4
5
水题。解法如下,开辟三个vector向量,vec用于储存乱序答案,pos用于存放输入数据,ans用于存放答案,最后逆序输出。
Tips:也可用list类型
#include <vector>
#include <iostream>
using namespace std;
int main(){
	int n,smallernum,p;
	cin>>n;
    vector<int> vec;
    vector<int> pos;
    vector<int> ans;
    	for(int i=1;i<=n;i++) vec.push_back(i);
        for(int j=0;j<n-1;j++){
        	cin>>p;
        	pos.push_back(p);
        }	
	vector<int>::iterator it = pos.end()-1;
	for(int i=0;i<n-1;i++){
	    ans.push_back(vec[*it]);
		vec.erase(vec.begin()+*it);
		it--;
	}
	ans.push_back(vec[0]);
	vector<int>::reverse_iterator rit; 
    for(rit = ans.rbegin(); rit != ans.rend(); rit++)  
    {  
        cout << *rit <<endl;  
    }  

}

31

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值