7-3 关于堆的判断(25 分)
将一系列给定数字顺序插入一个初始为空的小顶堆H[]
。随后判断一系列相关命题是否为真。命题分下列几种:
x is the root
:x
是根结点;x and y are siblings
:x
和y
是兄弟结点;x is the parent of y
:x
是y
的父结点;x is a child of y
:x
是y
的一个子结点。
输入格式:
每组测试第1行包含2个正整数N
(≤ 1000)和M
(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N
个要被插入一个初始为空的小顶堆的整数。之后M
行,每行给出一个命题。题目保证命题中的结点键值都是存在的。
输出格式:
对输入的每个命题,如果其为真,则在一行中输出T
,否则输出F
。
输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;
int a[1005];
int n;
string s;
int f(int x){
for(int i=1;i<=n;i++){
if(a[i]==x) return i;
}
return -1;
}
int main(){
int m;
cin>>n>>m;
cin>>a[1];
for(int i=2;i<=n;i++){
cin>>a[i];
for(int k=i;a[k]<a[k/2];k/=2)
swap(a[k],a[k/2]);
}
int x1,x2;
while(m--){
cin>>x1;
cin>>s;
if(s=="and"){
cin>>x2;
cin>>s;
cin>>s;
if(f(x1)/2==f(x2)/2)
cout<<"T"<<endl;
else cout<<"F"<<endl;
}else{
cin>>s;
if(s=="a"){
cin>>s;
cin>>s;
cin>>x2;
if(f(x1)/2==f(x2))
cout<<"T"<<endl;
else cout<<"F"<<endl;
}else{
cin>>s;
if(s=="root"){
if(a[1]==x1)
cout<<"T"<<endl;
else cout<<"F"<<endl;
}else{
cin>>s;
cin>>x2;
if(f(x2)/2==f(x1))
cout<<"T"<<endl;
else cout<<"F"<<endl;
}
}
}
}
return 0;
}