Catch That Cow
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 120633 | Accepted: 37641 |
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
广度优先搜索入门题目,类似的迷宫问题都可以用广搜解决
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<iostream>
using namespace std;
#define LL long long
#define M(a,b) memset(a,b,sizeof(a))
const int MAXN = 1e5+5;
int n,k;
int vis[MAXN];///标记
queue<int>q;
int bfs(int x)
{
q.push(x);
while(!q.empty())
{
int temp = q.front();
q.pop();
//printf("temp==%d\n");
if(temp==k)///找到终点
{
return vis[k];
}
if(temp+1>=0&&temp+1<=100000&&vis[temp+1]==0)
{
q.push(temp+1);
vis[temp+1] = vis[temp]+1;///步数等于上一步步数+1
}
if(temp-1>=0&&temp-1<=100000&&vis[temp-1]==0)
{
q.push(temp-1);
vis[temp-1] = vis[temp]+1;
}
if(temp*2>=0&&temp*2<=100000&&vis[temp*2]==0)
{
q.push(temp*2);
vis[temp*2] = vis[temp]+1;
}
}
}
int main()
{
while(~scanf("%d %d",&n,&k))
{
M(vis,0);
while(!q.empty()) q.pop();
vis[n]=1;
bfs(n);
printf("%d\n",vis[k]-1);///因为起始步数标记为1,所以终点步数要减去一
}
return 0;
}