1089 Insert or Merge (25 分)
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6
编写插入排序和归并排序代码,但是只需表示出每趟排序结果,不必太过注重细节,可以直接使用sort函数对每趟需排序的元素进行排序。
#include <stdio.h>
#include <cstdio>
#include <string>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <vector>
#include <stack>
#include <map>
#include <set>
using namespace std;
int a[101],b[101];
int n;
bool same(int t[])
{
for(int i=0;i<n;i++)
{
if(t[i]!=b[i])
{
return false;
}
}
return true;
}
int main(){
scanf("%d",&n);
int t1[101],t2[101];
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
t1[i]=a[i];
t2[i]=a[i];
}
for(int i=0;i<n;i++)
{
scanf("%d",&b[i]);
}
int flag=0;
for(int i=1;i<n;i++)
{
sort(t1,t1+i+1); //插入排序。处理很巧妙//
//坑点:第一趟排序应该是排序前两个数,第i趟排序分别排序前i+1个数 i+1:长度
if(same(t1)==true)
{
flag=1;
sort(t1,t1+i+2);
printf("Insertion Sort\n");
for(int j=0;j<n;j++)
{
if(j==0)
printf("%d",t1[j]);
else
printf(" %d",t1[j]);
}
printf("\n");
break;
}
}
if(flag==0)
{
for(int i=2;i<n;i*=2)
{
for(int j=0;j<n;j+=i)
{
if(j+i<n)
{
sort(t2+j,t2+j+i); //合并排序的难点
}
else
{
sort(t2+j,t2+n);
}
if(same(t2)==true)
{
for(int j=0;j<n;j+=i*2) //合并排序的难点
{
if(j+i*2<n)
sort(t2+j,t2+j+i*2);
else
sort(t2+j,t2+n);
}
printf("Merge Sort\n");
for(int j=0;j<n;j++)
{
if(j==0)
printf("%d",t2[j]);
else
printf(" %d",t2[j]);
}
printf("\n");
break;
}
}
}
}
}