贪心?——Supermarket

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.
这里写图片描述
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10
Sample Output
80
185
Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

开始觉得题目读懂了就做了。
结果第一次做的根本离了题意,还傻乎乎的觉得自己老对了。
题意:
每一个商品都有其价值和保质期。
一天只能卖一样。
如何在保质期之前合理安排每天卖的商品以保证最终利益最大。

第一遍想的思路暴露了我拖延症的思想。
将截止日期从晚到早排列,若是同一天截至,则卖价值大的。
为啥非要最后一天才卖呢?
空的天数干嘛闲着呢?
正确思路:
将商品利润从大到小排列,按截止日期从后向前推,有空儿就卖。

ps:二维排列到现在还要查就很不应该了。

#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
struct node{
    int pi;int di;
}nn[10000];
int a[10000];
bool cmp(node a,node b){
    if(a.pi!=b.pi)
        return a.pi>b.pi;
    else
        return a.di>b.di;
}
int main(){
    int n;
    while(cin>>n){
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++){cin>>nn[i].pi>>nn[i].di;}
        sort(nn,nn+n,cmp);
        int sum=nn[0].pi;a[nn[0].di]=1;
        for(int i=1;i<n;i++){
            while(nn[i].di>0){
                if(a[nn[i].di]==0){
                    sum+=nn[i].pi;
                    a[nn[i].di]=1;
                    //cout<<nn[i].pi<<" "<<nn[i].di<<endl;
                    //cout<<sum<<endl;
                    break;
                }
                nn[i].di--;
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值