1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

题意:有2个多项式,每行第一个(非零项)表示这个多项式有几个指数和系数,简单的说 2 1 2.4 0 3.2 表示这个多项式是2.4x^1+3.2x^0 = 2.4x+3.2
然后把这2个多项式相加,按同样的格式输出。

思路:题目规定指数的大小是NK>=0且NK<=1000的,所以可以专门准备一个数组x[1001],只要输入的数据中出现指数,那么就把该指数保存在index中,则该指数对应的系数保存在x[index].

注意:因为NK<=1000,有NK=1000的情况,所以数组要定成x[1001].

#include <stdio.h>

int main()
{
    int i,N,index;
    float num;
    float x[1001]={0};
    int n=0;
    scanf("%d",&N);
    while(N--)
    {
        scanf("%d",&index);
        scanf("%f",&num);
        x[index]+=num;
    }
    scanf("%d",&N);
    while(N--)
    {
        scanf("%d",&index);
        scanf("%f",&num);
        x[index]+=num;
    }
    for(i=0;i<=1000;i++)
    {
        if(x[i] != 0)
            n++;
    }
    printf("%d",n);
    for(i=1000;i>=0;i--)
    {
        if(x[i] != 0)
        {
            printf(" %d %.1f",i,x[i]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值