uva 572

本文介绍了一个用于探测矩形区域地下油藏的算法。该算法通过建立网格并分析每个单元格来确定不同油藏的数量。相邻的油藏单元被视为同一油藏的一部分。文章提供了完整的源代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides
the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to
determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the
same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number
of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting
the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the
absence of oil, or ‘@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same
oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2

#include<cstdio>
#include<cstring>
const int maxn = 100+5;

char pic[maxn][maxn];
int m , n ,idx[maxn][maxn];

void dfs(int x , int y , int id){
    if(x<0|| x>=m || y<0||y>=n) return ;
    if(pic[x][y] !='@' || idx[x][y] >0) return ;
    idx[x][y] = id;
    for(int i = -1 ; i<=1 ; i++){
        for(int j =-1 ; j<=1 ; j++){
            if(i != 0 || j != 0)
                dfs(x+i , y+j , id);
        }
    }
}
int main(){
    while(scanf("%d%d", &m , &n) == 2 && m &&n){
        for(int i = 0 ; i<m ; i++) scanf("%s" , pic[i]);
        memset(idx , 0 , sizeof(idx));
        int cnt =0 ;
        for(int i = 0 ; i< m; i++){
            for(int  j = 0 ; j<n ; j++){
                if(idx[i][j] == 0 && pic[i][j] == '@')
                    dfs(i , j , ++cnt);
            }
        }
        printf("%d\n" , cnt);

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值