传送门:点击打开链接
Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
Output
For each case, output a line contains the answer.
Sample Input
3 abc 1 abcabc 1 abcabc 2
Sample Output
6 15 21
Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
Output
For each case, output a line contains the answer.
Sample Input
3 abc 1 abcabc 1 abcabc 2
Sample Output
6 15 21
尺取法,有一点要注意:关于字符串子串数目的计算问题
int cnt = 0;
for(int i = 0; i < len; i++)
{
cnt = i + 1;
}
代码:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef pair<char, int>P;
const int inf = 0x3f3f3f3f;
char s[100005];
int cnt[30];
int main()
{
int t, k;
scanf("%d", &t);
while(t--)
{
memset(cnt, 0, sizeof(cnt));
scanf("%s", &s);
scanf("%d", &k);
int len = strlen(s);
ll ans = 0;
int it, is;
for(it = 0, is = 0; it < len; it++)
{
cnt[s[it]-'a']++;
if(cnt[s[it]-'a']>k)
{
for(;is <= it; is++)
{
cnt[s[is]-'a']--;
if(cnt[s[it]-'a']<=k)
break;
}
is++;
}
ans += (it-is+1);
}
printf("%lld\n", ans);
}
}