题目链接:http://poj.org/problem?id=2249
题目描述:
Description
In how many ways can you choose k elements out of n elements, not taking order into account?
Write a program to compute this number.
Input
The input will contain one or more test cases.
Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n).
Input is terminated by two zeroes for n and k.
Output
For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2 31.
Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.
Sample Input
4 2
10 5
49 6
0 0
Sample Output
6
252
13983816
题目分析:
组合数,注意要*一个数/一个数同时进行,不然中间可能某一步会越界
还有就是最后输出的时候要考虑不确定度
AC代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
int a,b;
int main()
{
while(1)
{
cin>>a>>b;
if(a==0&&b==0)
break;
b=min(b,a-b);
double x=1.0;
while(b>0)
{
x*=(a*1.0/b);
a--;
b--;
}
printf("%d\n",(int)(x+0.005));
}
return 0;
}