POJ3321:Apple Tree(树状数组)

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

这题是用树状数组求和,最关键的是如何把每个点与节点对应起来,我使用的方法是先用vector保存每个点与哪些点相邻,然后从节点1开始,往下进行dfs,相当于给每个找到的点一次对应1,2,3.....也就是lef里存的值,然后返回时tot是最远到达的那个点,就用rig存,这样在某一点以下的点就全找到了,我们利用树状数组的模板,求一下两个sum,再一减就可以得到结果。

#include <stdio.h>
#include <string.h>
#include <vector>
using namespace std;

const int maxn=100005;

vector<vector<int> > a(maxn);

int lef[maxn];
int rig[maxn];
int s[maxn];
int c[maxn];
int tot=1;
int n,m;

void dfs(int now)
{
	lef[now]=tot;
	int i;
	for(i=0;i<a[now].size();i++)
	{
		tot++;
		dfs(a[now][i]);
	}
	rig[now]=tot;
}

int lowbit(int k)
{
	return k&(-k);
}

int sum(int x)  
{  
    int ret = 0;  
    while(x>0)  
    {  
        ret+=c[x];  
        x-=lowbit(x);  
    }  
    return ret;  
}  

void add(int x,int d)  
{  
    while(x<=n)  
    {  
        c[x]+=d;  
        x+=lowbit(x);  
    }  
}

int main()
{
	while(~scanf("%d",&n))
	{
		memset(lef,0,sizeof(lef));
		memset(rig,0,sizeof(rig));
		memset(s,0,sizeof(s));
		memset(c,0,sizeof(c));
		int i,j;
		tot=1;
		for(i=0;i<=maxn;i++)
			a[i].clear();
		for(i=0;i<n-1;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			a[u].push_back(v);
		}
		dfs(1);
		for(i=1;i<=n;i++)
		{
			s[i]=1;
			add(i,1);
		}
		scanf("%d",&m);
		for(i=0;i<m;i++)
		{
			char cq[5];
			int cha;
			scanf("%s%d",cq,&cha);
			if(cq[0]=='Q')
			{
				int ans=sum(rig[cha])-sum(lef[cha]-1);
				printf("%d\n",ans);
			}
			else if(cq[0]=='C')
			{
				if(s[cha])
				{
					s[cha]=0;
					add(lef[cha],-1);				//注意此处用left[cha]
				}
				else
				{
					s[cha]=1;
					add(lef[cha],1);
				}
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值