The Dole Queue(子过程设计)(UVa 133)

The Dole Queue

Time Limit: 3000ms
Memory Limit: 131072KB
This problem will be judged on  UVA. Original ID:  133
64-bit integer IO format:  %lld      Java class name:  Main

[PDF Link]


 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.

代码分析:go()函数把一个走步的复杂功能从main中分离出来,增加了代码可读性。

#include<stdio.h>
#define MAXN 25

int n, k, m, a[MAXN];

int go(int p, int d, int k)	//起点坐标p,方向d(1逆时针,-1顺时针),步长k 
{
	while(k) 
	{
		
		while(a[(p = (p+d+n-1)%n+1)] == 0); //p = (p+d+n-1)%n+1保证p永远不会越界 
		k--;
	}
	return p;
}

int main()
{
	int p1, p2, left;
	while(scanf("%d %d %d", &n, &k, &m) == 3)
	{
		if(n==0 && k==0 && m==0) break;
		
		p1 = n;	//因为开始的起点算一步,所以从起点前一步开始算起
		p2 = 1; //同上
		left = n;
		for(int i=1; i<=n; i++) a[i] = 1;	//编号为1~n 
		
		while(left)
		{
			p1 = go(p1, 1, k);
			p2 = go(p2, -1, m);
			
			printf("%3d", p1);left--;a[p1]=0;
			if(p1 != p2) {printf("%3d", p2);left--;a[p2]=0;}
			if(left) printf(","); 
			
		}
		
		printf("\n");
		
		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值