题目
链接https://www.patest.cn/contests/pat-b-practise/1020
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式:
每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。
输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。
输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50
思路
考察结构体存储与对具体某一属性的排序 sort(a,a+n,cmp)
也可以使用容器
代码
#include<iostream>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
struct mooncake
{
double weight;//总重量
double per_price;//单价
double total_price;//总价格
};
bool cmp(mooncake x, mooncake y)//要定义成bool形 才学会的结构体具体属性的排序
{
return x.per_price<y.per_price;
}
int main()
{
//freopen("in.txt" , "r" , stdin);
int num;
double sum=0,w_total;//w_total重量的月饼价格sum
cin>>num>>w_total;
mooncake a[1000];
int i;
for(i=1;i<=num;i++)
cin>>a[i].weight;
for(int j=1;j<=num;j++)
{
cin>>a[j].total_price;
a[j].per_price = a[j].total_price/a[j].weight;
}
sort(a,a+num+1,cmp);
i = num;//此时i指向单价最高的 排序后的
while(w_total>=0&&i>=1)
{
if(w_total>a[i].weight)
sum+=a[i].total_price;
else
sum+=w_total*a[i].per_price;
w_total-=a[i].weight;
i--;
}
printf("%.2f\n",sum);
return 0;
}