PAT(stl)——1100 Mars Numbers (20 分)

本文介绍了一种将地球上的十进制数转换为火星上十三进制数的方法,以及反之亦然。通过使用特定的词汇表,程序能够实现两种计数系统之间的互译,为跨星球交流提供便利。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earch is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:
For each number, print in a line the corresponding number in the other language.

Sample Input:
4
29
5
elo nov
tam
Sample Output:
hel mar
may
115
13

题目大意:

一道20分的模拟水题,花了1个小时才通过。具体看代码。

题目解析:
具体代码:
#include<iostream>
#include<algorithm>
#include<map>
#include<cmath>
using namespace std;
string x[13]={"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string y[13]={"undefined","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
map<string,int> m;
void init(){
	for(int i=0;i<13;i++){
		m[x[i]]=i;
		m[y[i]]=i*13;
	}
}
int main()
{
    int n;
    cin>>n;
    init();
    getchar();
    while(n--){
    	string s;
    	getline(cin,s);
    	if(isdigit(s[0])){//处理数字 
			int num=stoi(s);
			int arr[3],k=0;
			do{
				arr[k++]=num%13;
			}while(num/=13);
			if(k>1){//有十位
				cout<<y[arr[1]];
				if(arr[0]!=0)
					cout<<" "<<x[arr[0]];
				cout<<endl;
			}else{
				cout<<x[arr[0]]<<endl;
			}
		}else{
			string tmp;
			int num=0;
			for(int i=0;i<s.size();i++){
				if(s[i]==' '){
					num+=m[tmp];
					tmp.clear();
				}else
					tmp+=s[i];
			}
			num+=m[tmp];
			cout<<num<<endl;
		}
	}
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值