POJ 1386 Play on Words 判欧拉路

Play on Words
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11835 Accepted: 4046

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

Source

    题意:字母尾字母和另一个字母首字母相同的话,则可以将这两个字母连接。问最终是否能将给出的字母连成一串。

    分析:可以转换成欧拉路问题,一个字母抽象成首字母指向尾字母的边,将字母抽象成数字即可,本质上是有向图欧拉路问题。有向图欧拉路存在的话,则图连通,且有一点出度比入度大1,有一点入度比出度大1,且其他所有点入度等于出度。有向图欧拉回路存在的话,则所有点出度等于出度。先使用并查集判断连通性,然后再根据入度出度判断即可。见AC代码:

//思路 该题抽象成t图
//起点为首字母  终点为末字母
//使用并查集判断连通性
//后根据图的欧拉路判断法则 可以判断是否构成欧拉路
#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
using namespace std;
int in[26],out[26],vis[26],pre[26];
char temp[1005];
int find(int x)
{
	int r=x;
	while (pre[r]!=r)
		r=pre[r];
	int i=x,j ;
	while( i != r )
	{
		j=pre[i];
		pre[i]=r ;
		i=j;
	}
	return r ;
}
void join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
		pre[fx]=fy;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		scanf("%d",&n);
		memset(in,0,sizeof(in));
		memset(vis,0,sizeof(vis));
		memset(out,0,sizeof(out));
		for(int i=0; i<26; i++)
			pre[i]=i;

		for(int i=0; i<n; i++)
		{
			scanf("%s",temp);//注意不要使用string
			int len=strlen(temp);
			int from=temp[0]-'a',to=temp[len-1]-'a';
			out[from]++;//标记出度
			in[to]++;//标记入度
			vis[from]=1;//用到
			vis[to]=1;//用到
			join(from,to);//不需要输出路径 判断连通性可以用并查集
		}
		int cnt=0;
		for(int i=0; i<26; i++)
		{
			if(vis[i]&&pre[i]==i) //从用到的点中选出 存在几个群体
			{
				cnt++;
			}

		}
		if(cnt>1)//图不连通
		{
			printf("The door cannot be opened.\n");//图不连通
			continue;
		}
		int cnt1=0,cnt2=0,cnt0=0,cnt4=0;
		for(int i=0; i<26; i++)
			if(vis[i])
			{
				if(in[i]-out[i]==1)
					cnt1++;
				else if(in[i]-out[i]==-1)
					cnt2++;
				else if(in[i]-out[i]==0)
					cnt0++;
				else
					cnt4++;
			}
		if(cnt4)
		{
			printf("The door cannot be opened.\n");
		}
		else
		{
			if((!cnt1&&!cnt2)||(cnt1==1&&cnt2==1))
				printf("Ordering is possible.\n");
			else
				printf("The door cannot be opened.\n");
		}

	}
	return 0;
}
    特记下,以备后日回顾。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值