杭电 1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 172675    Accepted Submission(s): 40223


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

分析:

 

这是一道求最大子段和的问题.

定义一个初始值为-1001max(测试数据最小为-1000)从第一个数开始累加sum

每次累加之后与max打擂,若大于则更新子段的终止位置。

sum<0则丢弃之前的子段,从终止位置的下一位置重新开始;

直到再找到一个更大的子段,更新起始位置;

 

第一次做的时候在sum<0时直接就更新了起始位置到当前位置的下一位置,导致WA

(应该确保之后找到了更大的子段和时才更新起始位置。)因此纠结了好半天;

 

 

代码:

 

#include<iostream>

using namespace std;

int main()

{

int k;

cin >> k;

for (int j = 1;j <= k;j++)

{

int begin = 1, end, begin_t=1;

int sum = 0, max = -1001,shuru;

int n;

int i;

cin >> n;

for (i = 1;i <= n;i++)

{

scanf_s("%d", &shuru);

sum += shuru;

if (sum > max)

{

max = sum;

end = i;

begin = begin_t;

}

if (sum < 0)

{

sum = 0;

begin_t = i + 1;

}

}

printf("Case %d:\n", j);

printf(j==k ? "%d %d %d\n" : "%d %d %d\n\n", max, begin, end);

}

return 0;

}

 

 

 

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值