hdu1010:Tempter of the Bone

题目链接

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 116598    Accepted Submission(s): 31609


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
YES
 

Author
ZHANG, Zheng
 
题意: 给你m * n 的迷宫, 有一只小狗重起点S开始出发要正好T步走到迷宫的终点D, 能就输出YES, 不能就输出NO。

解题思路:
DFS  + 奇偶剪枝。 直接DFS会超时。

将该迷宫看成0,1 交替的如下形式:
0 1 0 1 0 1 0
1 0 1 0 1 0 1
0 1 0 1 0 1 0
1 0 1 0 1 0 1
然后就会发现从0走到0或从1走到1的不论怎么走都是偶数步数,从0走到1或从1走到0都是奇数步数,
假设我们所在的点是sx, sy。 终点是ex, ey。如果起点是0走到0或1走到1的情况那么T(这里的T是指
当前还剩余的步数)必须是偶数, 反之必须是奇数。

我们能够求出 t1 = abs(sx - ex) + abs(sy - ey)是从起点到终点所需要的最少步 数。
那么T和t1的奇偶性必须相同,如果不相同, 则直接舍去(这里就是剪枝, dfs过程中不用再深搜下去)。
  因为奇数减去奇数是偶数, 偶数减去偶数是偶数所以(T-t1)%2 判断奇偶性即可( 但要注意如果T-t1<0的话步数 不够也应直接舍去) 在DFS 搜索过程中碰到以上情况的直接return,不用继续深搜下去以节省时间。

代码:
#include <cmath>
#include <string>
#include <cstdio>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LOCAL
using namespace std;

int f[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};  //方向
char s[10][10]; 
int m, n, t;
int si, sj, ei, ej;
int flag = 0;

void dfs(int x, int y, int z)
{
    if(flag == 1) return;   

    if(t == z && x == ei && y == ej)   //到达终点
    {
        flag = 1;
        return;
    }
    if(x <= 0 || x > m || y <= 0 || y > n)  //判断边界
        return;

    int t1 = t - z - abs(x - ei) - abs(y - ej);
    if(t1 < 0 || t1&1)                       //这里就是奇偶剪枝
        return;

    for (int i = 0; i < 4; i++)
    {
        int nx = x + f[i][0];
        int ny = y + f[i][1];

        if(s[nx][ny] != 'X')
        {
            s[nx][ny] = 'X';                    //标记走过
            dfs(nx, ny, z+1);
            s[nx][ny] = '.';                    //还原地图
        }
    }
    return;
}

int main()
{
//    #ifdef LOCAL
//    freopen("data.in", "r", stdin);
//    freopen("data.out", "w", stdout);
//    #endif
    while (scanf("%d%d%d",&m, &n, &t) != EOF)
    {
        getchar();

        if(m == 0 && n == 0 && t == 0) break;
        memset(s, 0, sizeof(s));

        int wall = 0;

        for (int i = 1; i <= m; i++)
        {
            for (int j = 1; j <= n; j++)
            {
                scanf("%c", &s[i][j]);
                if(s[i][j] == 'S')
                {
                    si = i; sj = j;
                }
                else if(s[i][j] == 'D')
                {
                    ei = i; ej = j;
                }
            }
            getchar();
        }

        flag = 0;
        s[si][sj] = 'X';         //出发点要记得标记走过, 之前因为没有标记导致WA。
        dfs(si, sj, 0);

        if(flag == 1)
            printf("YES\n");
        else
            printf("NO\n");
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值