poj2311 Cutting Game-----sg

这篇博客探讨了POJ2311问题中的切割游戏,解释了游戏规则:先切出单个格子者获胜。2和3被视为结束状态,3*2、2*3、2*2同样视为终止条件。游戏从2开始进行循环分析。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 

 

Cutting Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2015 Accepted: 710

Description

Urej loves to play various types of dull games. He usually asks other people to play with him. He says that playing those games can show his extraordinary wit. Recently Urej takes a great interest in a new game, and Erif Nezorf becomes the victim. To get away from suffering playing such a dull game, Erif Nezorf requests your help. The game uses a rectangular paper that consists of W*H grids. Two players cut the paper into two pieces of rectangular sections in turn. In each turn the player can cut either horizontally or vertically, keeping every grids unbroken. After N turns the paper will be broken into N+1 pieces, and in the later turn the players can choose any piece to cut. If one player cuts out a piece of paper with a single grid, he wins the game. If these two people are both quite clear, you should write a problem to tell whether the one who cut first can win or not.

Input

The input contains multiple test cases. Each test case contains only two integers W and H (2 <= W, H <= 200) in one line, which are the width and height of the original paper.

Output

For each test case, only one line should be printed. If the one who cut first can win the game, print "WIN", otherwise, print "LOSE".

Sample Input

2 2
3 2
4 2

Sample Output

LOSE
LOSE
WIN

Source

POJ Monthly,CHEN Shixi(xreborner)

 

谁先切出一个单个的格子谁就赢了。

2,3都是终止状态,把3*2、2*3、2*2都看成终止状态,所以从2开始循环

 

#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
using namespace std;
int sg[210][210];
int dfs(int n,int m)
{
    if(sg[n][m]>=0) return sg[n][m];
    bool g[210]={0};
    for(int i=2;i<=n/2;i++)
    {
        g[dfs(i,m)^dfs(n-i,m)]=1;
    }
    for(int i=2;i<=m/2;i++)
    {
        g[dfs(n,i)^dfs(n,m-i)]=1;
    }
    for(int i=0;;i++)
    if(g[i]==0) return sg[n][m]=i;
}
int main()
{
    memset(sg,-1,sizeof(sg));
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(dfs(n,m)>0) puts("WIN");
        else puts("LOSE");
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值