###题目来源:
hdu1015 Safecracker
Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST ===
“The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein’s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, …, Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.”
$v - w^2 + x^3 - y^4 + z^5 = target $
“For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn’t exist then.”
=== Op tech directive, computer division, 2002/11/02 12:30 CST ===
“Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution’ if there is no correct combination. Use the exact format shown below.”
Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
Sample Output
LKEBA
YOXUZ
GHOST
no solution
##题意:
用字符串表示数字,在已知的字符串 s 遍历v、w、x、y、z 满足公式 v - w^2 + x^3 - y^4 + z^5 = tar的最大字符串。
##解题思路:
此种类型的题目数据量很小,可以直接暴力求解,利用标记数组和两个额外的保存数组进行循环,暴力求解就行,其中需要注意的是当有多个解同时存在的时候需要输出最大的一个解,这时候就需要利用两个额外的数组进行先后两个解得存储和比较。
View Code:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int main(){
int n;
char mis[15],kis[6],tis[6];
while(scanf("%d%s",&n,mis)&&(n||strcmp(mis,"END"))){
getchar();
int dis[15];
int vis[15]={0},m=0,i,j,k,x,y,flag=0;
for(i=0;mis[i]!='\0';i++,m++) dis[i]=mis[i]-64;
m--;
memset(tis,'\0',sizeof(tis));
for(i=m;i>=0;i--){
if(vis[i]==1) continue;
vis[i]=1;
for(j=m;j>=0;j--){
if(vis[j]==1) continue;
vis[j]=1;
for(k=m;k>=0;k--){
if(vis[k]==1) continue;
vis[k]=1;
for(x=m;x>=0;x--){
if(vis[x]==1) continue;
vis[x]=1;
for(y=m;y>=0;y--){
if(vis[y]==1) continue;
if(dis[i]-dis[j]*dis[j]+dis[k]*dis[k]*dis[k]-dis[x]*dis[x]*dis[x]*dis[x]+dis[y]*dis[y]*dis[y]*dis[y]*dis[y]==n) {
kis[0]=mis[i];
kis[1]=mis[j];
kis[2]=mis[k];
kis[3]=mis[x];
kis[4]=mis[y];
kis[5]='\0';
if(strcmp(kis,tis)>0) strcpy(tis,kis);
flag=1;
break;
}
}
vis[x]=0;
}
vis[k]=0;
}
vis[j]=0;
}
vis[i]=0;
}
if(flag==1)cout<<tis<<endl;
else cout<<"no solution"<<endl;
}
}